Braker2 gene prediction usage

Dear IFB team,

I have been trying to use Braker2 pipline to annotate an eukaryotic genome. However I have been receiving the following error message related to Augustus:

#                               BRAKER CONFIGURATION                               
# BRAKER CALL: /shared/ifbstor1/software/miniconda/envs/braker2-2.1.4/bin/ --genome B70.soft.mask.fasta --bam B70.trans_sorted.bam --softmasking --cores 54
# Thu Sep 30 16:59:09 2021: version 2.1.4
# Thu Sep 30 16:59:09 2021: Configuring of BRAKER for using external tools...
# Thu Sep 30 16:59:09 2021: Found environment variable $AUGUSTUS_CONFIG_PATH. Setting $AUGUSTUS_CONFIG_PATH to /shared/ifbstor1/software/miniconda/envs/augustus-3.3.3/bin/augustus
# Thu Sep 30 16:59:09 2021: ERROR: in file /shared/ifbstor1/software/miniconda/envs/braker2-2.1.4/bin/ at line 1553
AUGUSTUS_CONFIG_PATH/species (in this case /shared/ifbstor1/software/miniconda/envs/augustus-3.3.3/bin/augustus/) is not writeable.
There are 3 alternative ways to set this variable for
   a) provide command-line argument --AUGUSTUS_CONFIG_PATH=/your/path
   b) use an existing environment variable $AUGUSTUS_CONFIG_PATH
      for setting the environment variable, run
           export AUGUSTUS_CONFIG_PATH=/your/path
      in your shell. You may append this to your .bashrc or
      .profile file in order to make the variable available to all
      your bash sessions.
   c) can try guessing the location of
      $AUGUSTUS_CONFIG_PATH from an augustus executable that is
      available in your $PATH variable.
      If you try to rely on this option, you can check by typing
           which augustus
      in your shell, whether there is an augustus executable in
      your $PATH
      Be aware: the $AUGUSTUS_CONFIG_PATH must be writable for
       because is a pipeline that
                optimizes parameters that reside in that
                directory. This might be problematic in case you
                are using a system-wide installed augustus 
                installation that resides in a directory that is
                not writable to you as a user.

I tried to run with and without loading the the module of Augustus, but it does not works. As far as I understand this is due to the lack of permissions on Augustus as the c) option says. Therefore I would like to know, to use braker on the cluster Do I need to install Augustus? or it exists other way to run it?

Thank you in advance,



Yes it look like the perl script need to be able to write in the augustus config folder.

Maybe you can try to set the variable AUGUSTUS_CONFIG_PATH to a folder you have write access (for example in your project directory) as suggested in the b) case

If it does not work, maybe you can create a conda env in your project space with both augustus and braker2.

Thank you,
Just setting the variable did't worked, so I will try the environment conda option.