Converting a Metabolights study to W4M format fails

Error when trying to convert Metabolights study MTBLS174 to W4M format with "ISA to W4M" tool:

   Traceback (most recent call last):
|   File "/shared/mfs/data/galaxy/mutable-data/shed_tools/", line 8, in <module>
|   isatab2w4m.main()
|   File "/shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/__isatools@0.10.3/lib/python3.8/site-packages/isatools/convert/", line 569, in main
|   convert(input_dir           = args_dict['input_dir'],
|   File "/shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/__isatools@0.10.3/lib/python3.8/site-packages/isatools/convert/", line 548, in convert
|   assays = convert2w4m(input_dir      = input_dir,
|   File "/shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/__isatools@0.10.3/lib/python3.8/site-packages/isatools/convert/", line 458, in convert2w4m
|   variable_names = make_variable_names(measures_df)
|   File "/shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/__isatools@0.10.3/lib/python3.8/site-packages/isatools/convert/", line 295, in make_variable_names
|   if assay_df.keys().contains(col):
|   AttributeError: 'Index' object has no attribute 'contains'


I think I have a similar issue than [quote="pkrog, post:1, topic:573"]

I want to work with MTBLS719 study. any idea @Lain @pkrog ?


it seems to be a pandas version problem in the isatools package.
I don't know much, as I don't know isatools nor pandas.

EDIT: well... perhaps it never worked..? and in this case it's an isatools issue.


Sorry not to be able to answer your question, maybe @pkrog would know more about the tool

here my history Galaxy | France | Accessible History | MTBLS719_EBI

Many Thanks for your time

Hi @yguitton , @Lain ,
I will have a look at this issue and try to solve it quickly.

Does anyone know with which Python 3 version tools are running on Workflow4metabolomics Galaxy platform? @gildaslecorguille , @yguitton ?

In the error message, it's said that it is python3.8.

Oh ! I did not find that in Yann's history, thanks. Anything more precise than 3.8?

I can't access the cluster's files with a regular account.
Only a sysadmins would be able to do so.
Perhaps @gildaslecorguille ?

I see the isatools version is 0.10.3 in the error message, and I have some error with pandas when running this version on my computer. Version 0.12.2 solves this issue and I can extract correctly study 174.
Checking now study 719.

For study 719, I get the same error as Yann:

ValueError: ('Could not resolve Protocol parameter from Parameter Value ', 'Extraction Method')

I don't know if this error is from isatools package or from the study content, so I've posted an issue on isatools GitHub repos.
In the meantime I will push a new version of isa2w4m tool so it works at least with MTBLS174.

Hi many thanks for the efforts. I hope the isatool will work for the 719 study would be really good, at least for me😉

OK, after a long time trying to run planemo test successfully, the new version that handles MTBLS174 (but not 719) is ready.
I have pushed it on Galaxy Test Tool Shed:
Who is in charge of installing it on W4M?

you can follow the merge request's progress here:

is the install urgent, or is it ok if the install is done this week-end?
New revisions are automatically installed on the week end.

@yguitton I let you answer about the urgency level.
Could you tell me where does come from the MTBLS719 study? Have you the possibility to check with Metabolights if the study is well written? The error is :

ValueError: ('Could not resolve Protocol parameter from Parameter Value ', 'Extraction Method')

Maybe there is a missing field inside the study.

@Lain @pkrog
Thanks for your help

Regarding delays would be cool to have the solution before May 24

For MTBLS719, it's a study from imperial college I can try to reach them (I know a bit one of the team members) and in parallel I can ask Metabolights for support (@pkrog do you have a direct contact there?)


No, I have no contact anymore at Metabolights, sorry.

Hi @pkrog @Lain

I just received an answer from Metabolights

"This was the result of a sneaky error in the ‘i_Investigation.txt’ for
MTBLS719 (re ‘Study Protocol Parameters Name’) which has now been fixed."

I will relaunch the job as soon as the new version of the tool is available on Galaxy