Errors in fillpeaks function

Dear colleagues,
I hope everyone is enjoying!
I was trying to process my data. everything was fine before fillPeaks. I tried several times but failed. Can you suggest where I could be wrong.


Hi @Dinesh_Thakur

Can you share your history with me ?


Hi dear,
Thanks for help. I was trying with 193 mzXML files. everything up to groupChromPeaks was completed successfully but there was repeatedly error in next steps.
Do you have any idea why this happens.


maybe @team.w4m have any ideas ?

I can have a look at the error. Can you please share the history (peteram), or if data are sensitive at least share the standard output message and error message?

I got this error

Defining peak areas for filling-in .... OK
Start integrating peak areas from original files
Requesting 584 peaks from Sample 132 ESI+.mzXML ... Error in binYonX(mz, int, breaks = brks, fromIdx = fromIdx, toIdx = toIdx, :
'fromIdx' and 'toIdx' have to be >= 0!
Calls: fillChromPeaks ... tryCatch -> tryCatchList -> tryCatchOne ->
Execution halted

I will need further info to investigate.

  • How many ions do you have in your dataset?
  • What steps of XCMS did you use from findChromPeaks to fillChromPeaks? Which versions of Galaxy tools?
  • Did you noticed something particular with Sample132 during the process? Do you get the same error message with fillChromPeaks if you try extracting your data without this specific sample?