Expected bowtie2 to be in same directory with bowtie2-align: /var/spool/slurm/slurmd/job148222/ Exiting now

Bonjour,
J’ai participé à la formation de 2018 à Roscoff ainsi je travaille avec le module conda sur eba2018_chipseq.
Alors après vérification de la qualité de mes fichiers fastq j’essaie de les maper à l’aide de bowtie2. J’ai du génome de souris en single read de 75pb.
Je suis allé chercher des index sur le site bowtie2 (en vrai j’en ai essayé plusieurs… même en bowtie1).
Actuellement lorsque je lance ma ligne de commande :
sbatch --mem=40GB bowtie2 -x …/index btw2/mm10/mm10 -U …/…/01-qualitycontrol/WT/WT-050318_S1_R1_001.fastq -S WT-050318_S1_R1_001.sam

Mobaxterm m’indique “Submitted batch job 151967” (dernier tentative en date c’est ce chiffre).
Sont créés des fichiers “slurm-151967.out” qui ne fontt qu’1KB et voilà.
J’ai essayé bowtie2-align mais il ne trouve pas la fonction “unable to open file bowtie2-align”.
J’ai essayé plusieurs choses mais j’avoue être assez perdu pour me débloquer de cette impasse.

Merci pour votre aide !
Bonne journée
Florian

Bonjour @FlorianReb

Ravis de te revoir sur l’IFB Core Cluster.

Dans ta ligne de commande, je vois plusieurs soucis


Pour revenir en arrière, il ne faut pas 3 . mais 2: ..

…/index btw2/mm10/mm10
Il faut éviter le plus possible les espaces dans les noms de dossier. Donc soit tu renommes ton dossier index btw2 en index_bwt2 (ce que je te recommande) soit tu mets des " autour du nom de ton dossier

sbatch
Je pense que ce que tu souhaites utiliser est un srun ?
sbatch va demander l’écriture d’un fichier. Par contre l’inconvénient de srun est que tu devras garder ta connection ouverte jusqu’à la fin de ton job. Si c’est court, ça va mais si il est long, à la moindre interruption réseau, tu perds ton job.

Ca donnerait ça :
srun --mem=40GB bowtie2 -x "../index btw2/mm10/mm10" -U ../../01-qualitycontrol/WT/WT-050318_S1_R1_001.fastq -S WT-050318_S1_R1_001.sam

2 J'aimes

Nous pouvons vous mettre à disposition des banques publics indexées sur demande.
Procéder ainsi permet de gagner de la place sur les espaces projets individuels.

Je m’occupe de mm10 asap :slight_smile:

Super merci !! ça tourne :slight_smile:
Je pense que ça va être long. Il y a donc une alternative pour ne pas prendre le risque d’avoir une interruption et de tout perdre ?
J’ai 8 échantillons à mapper en plus donc dans un monde idéal je lance le tout sur la nuit (ou plus) et ça tourne…

Merci !

Voici la documentation IFB Core Cluster dédiée à Slurm : http://taskforce-nncr.gitlab.cluster.france-bioinformatique.fr/doc/slurm_user_guide/

#!/bin/bash
#
#SBATCH --mem 40GB
bowtie2 -x hg19 -1 sample_R1.fq.gz -2 sample_R2.fq.gz -S sample_hg19.sam
$ sbatch myscript.sh

Envisage aussi d’utiliser plusieurs CPU : http://taskforce-nncr.gitlab.cluster.france-bioinformatique.fr/doc/slurm_user_guide/#parameters-for-multithreading

Encore moi.
J’avais quand même lancé en srun et au bout de 3h (et 8gb de fichier) j’ai eu ce message "an error occured while starting the following MobaXterm subprocess: “C:\Users\DOCUME~1\MobaXterm\slash\bin\MobaSCPRI.exe”.

Sinon pour sbash voilà la ligne de code que j’ai tenté en passant par un script.

vi slurm_mappingmychipseq.sh

#!/bin/bash

#SBATCH -p long
#SBATCH --ntasks-per-node=10
#SBATCH --mem 40GB
#SBATCH -t 0-15:00
#SBATCH --mail-user=florian.rebeillard@inserm.fr
bowtie2 --threads $SLURM_CPUS_PER_TASK -x …/index_btw2/mm10/mm10 -U …/…/01-qualitycontrol/WT/WT-050318_S1_R1_001.fastq -S WT-050318_S1_R1_001.sam
bowtie2 --threads $SLURM_CPUS_PER_TASK -x …/index_btw2/mm10/mm10 -U …/…/01-qualitycontrol/WT/WT-121118_S3_R1_001.fastq -S WT-121118_S3_R1_001.sam

$ sbatch slurm_mappingmychipseq.sh
Réponse : “error : unable to open file slurm_mapping…”.
Merci encore de ton aide.

PS j’ai bien mis 2 points et non 3 pour revenir en arrière c’est une correction automatique du logiciel je pense…

Bonjour Florian,

Lorsque l’on exécute sbatch slurm_mappingmychipseq.sh, on doit se trouver au même endroit que le script slurm_mappingmychipseq.sh.
Il faut sinon indiquer le chemin complet: sbatch <mondossier>/slurm_mappingmychipseq.sh

Un erreur s’est aussi glissé dans le script.
Il ne faut pas oublier de charger les logiciels ou environnements conda à l’interieur du script en faisant appel au commandes conda et/ou module.
Via

module load eba_chipseq/2018

ou

module load conda
source activate eba2018_chipseq

Enfin, si tu veux recevoir des mails, il faut aussi préciser sur quel type d’évenement (souvent on utilise “ALL”). Option --mail-type de sbatch

Le script devrait ressembler alors à:

#!/bin/bash

#SBATCH -p long
#SBATCH --ntasks-per-node=10
#SBATCH --mem 40GB
#SBATCH -t 0-15:00
#SBATCH --mail-user=florian.rebeillard@inserm.fr
#SBATCH --mail-type=ALL

module load eba_chipseq/2018

bowtie2 --threads $SLURM_CPUS_PER_TASK -x ../index_btw2/mm10/mm10 -U ../../01-qualitycontrol/WT/WT-050318_S1_R1_001.fastq -S WT-050318_S1_R1_001.sam
bowtie2 --threads $SLURM_CPUS_PER_TASK -x ../index_btw2/mm10/mm10 -U ../../01-qualitycontrol/WT/WT-121118_S3_R1_001.fastq -S WT-121118_S3_R1_001.sam

Bonne continuation et bonne soirée

1 J'aime

Merci pour ce retour. J'ai désactivé une option du forum Discourse pour éviter ces prises d'initiative typologique.
L'autre conseil est de placer vos lignes de code dans entre ``` (https://www.markdownguide.org/extended-syntax/#fenced-code-blocks)