Galaxy: history sharing compromised

Hi there,

This morning I wanted to share some history using a link. I went to the dedicated option and made my history accessible via link. Everything seemed to go smoothly... Or so I thought!

Here's the problem: when someone (including me, connected) want to access the link, it fails. You can give it a try with this "reproduce-the-error" history:
https://workflow4metabolomics.usegalaxy.fr/u/m.petera/h/totolerigolo
What you get is this:


(well, I try to stay cheerful, it's friday y'know)

I also tryed to make the history publicly available. You can see it on the list :


It leads to the same 404 Not Found thing.

Any idea why it does not work anymore?

(Thanks for the :musical_note:)

Hum, indeed, with the update of Galaxy, we activated the GDPR setting. It seems that it changed something ...

I tried to reproduce this issue. I took my regular (not admin) account and just click on "Make History Accessible wi Link"

I manage to get it.

I tryed clicking on your link, it worked well.
Could this be due to my account then? I did not change a thing compared to before.

Ping @team.galaxy

@melpetera It would be strange but can you remove the . in your public name?

1 J'aime

Well, I just did it and... now it works well!

So the point it was... Maybe the previous Galaxy version was nice enough to let it work, but the new one won't let me go against the rules :stuck_out_tongue_winking_eye:

Thanks :slight_smile:

Here is the exchange I had with the Galaxy team: https://github.com/galaxyproject/galaxy/issues/11209

You shouldn't be allow to add a . during your registration. They will fix that.