Installation de paquets R pour l'école DUBii (module 6)

Bonjour @team.r

Pour le module 6 des cours du DUBii, les paquets R suivants seraient nécessaires:

Pourriez-vous les installer, s'il-vous-plaît ? Le module se déroulera du 30 mars au 1er avril, mais les formateurs aimeraient réaliser des tests avant, si possible.

Merci d'avance !

Olivier

Hello Olivier,

En R 4.0.2 ?

Julien

Salut Julien,

Oui, je pense. C'est pour une utilisation avec RStudio. Y a-t-il d'autres choix de version avec celui-ci ?

Olivier

Salut,

Oui Rstudio est sur la version 4.0.2 de R.

Parcontre je pense que plusieurs de ces packages sont déjà installés.

Hello François,

Je ne les trouve pas dans /shared/ifbstor1/software/miniconda/envs/r-4.0.2/lib/R/library. Ils peuvent être ailleurs ?

Olivier

Ouaip, j'ai rien dit, tu as raison :wink:

Ils sont du coup en cours d'installation:

1 J'aime

Salut,

Ça a était un peu galère, mais ça devrait être bon.

La plupart des packages dans conda et/ou bioconductor sont compilés avec R 4.0.3 alors qu'on utilise la 4.0.2 ...

A votre avis ça vaux le coup de passer à cette nouvelle version ? Sachant aussi que la 4.0.4 est en train de sortir en ce moment ?

ps : ma question est d'ordre général, pas seulement pour dubii

Merci, François. Tout y est, en tout cas. Je vais en avertir les utilisateurs et je te préviendrai en cas de problème.

Pour la version de R, je ne sais pas. Sans doute pas pour le DUBii de cette année, si les packages s'installent malgré tout.

1 J'aime

Bonjour @team.r,

Pourriez-vous encore ajouter le package omicade4 de Bioconductor, s'il-vous-plaît ?

Merci !

Olivier

Bonjour,

Installation en cours:

1 J'aime