Installation SciPy @team.software

Bonjour,

Serait-il possible d'installer le module SciPy (module Python).
Je pense qu'un simple : pip install scipy devrait fonctionner.

Merci d'avance,

Guillaume

Bonjour,

Il me semble qu'il est installé dans le module python:

module load python/3.7
pip list | grep -i scip

Est-ce que cette solution vous convient ?

Il semble que ça soit bon ; le pipeline fonctionne sous python 3.9 mais cette partie devrait pouvoir fonctionner avec la 3.7 - je n'avais pas pensé à vérifier les autres versions.

Je fais les tests et si tout fonctionne bien, je validerai votre réponse comme solution si cela vous va.

Dans tous les cas, merci pour votre réactivité,

Guillaume.

On peux faire un env python 3.9 si vous le souhaitez (ca fait un moment que je me dis que ca serait une bonne idée)

La partie fonctionne bien sous python 3.7 donc en soit, les choses sont ok de mon côté.

L'idée d'un env python 3.9 serait intéressante, sachant que plusieurs des modules que j'utilise sont apparemment uniquement installés sous python 3.9 sur le cluster (pyslim entre autres), raison pour laquelle je travaillais spécifiquement sous cette version.

En tout cas, merci à vous,

Guillaume

Installation python 3.9 en cours:

c'est le même que python 3.7 mais avec la version de python mise à jour

2 J'aime