504 gateway timeout rstudio ondemand

Hi, I'm trying to access rstudio via the ondemand portal but independently of how many resources I allocate to it I can't connect to the rstudio and get error 504 gateway timeout when trying to access the instance. I can regularly access rstudio from the rstudio older portal but I'm having issues with the older 4.11 version on it for some compatibility with some packages. Yesterday morning and for all of Wednesday I was able to access it just fine.


Could you try to clean session files and cache ?
See: https://ifb-elixirfr.gitlab.io/cluster/doc/troubleshooting/#rstudio-timeout-or-do-not-start

Hi, I tried it all steps and while it couldn't rm .rdata as it didn' find any such file, all the other commands worked fine from the console but I still can't access any rstudio session with the main account, I haven't tried the demo as instances there are perma queued.
My temporary solution is to either run it very slowly locally or use the old portal with the old r until it works but it's far from ideal as I have no choice in either version or resource allocation

Hi Angelo,

You use the "demo" account. Please switch to your "project" account (epigenomic_id_methylation).
Explanations here: https://ifb-elixirfr.gitlab.io/cluster/doc/troubleshooting/#slurm-invalid-account-or-accountpartition-combination-specified

But I'm not sure to fully understand your issue.
Some of your jobs had not sufficient memory (OUT_OF_MEMORY) but others seem running well (maybe with too much ressources, please use it wisely).
Could you precise your error ?

My issue was with the 504 gateway access, the instances would start but I couldn't access them, now thanks to your help I can change the account in the command line and cleaned the data but the instances I start now with the methylation account go into undetermined state instead saying "Your session has entered a bad state. Feel free to contact support for further information.".

Regarding the resources I will be more mindful of resource use, I will try running the bigger of the 2 datasets and choose for the next sessions accordingly using the linked guide, I'm still trying to figure out how many resources the pipeline needs, I just know that the puny 16gbs of my local machine get saturated even in the 6x smaller dataset.

Upon restarting the browser it doesn't go into an undetermined state anymore but it's back to going to " 504 Gateway Time-out
The server didn't respond in time." when I try to click to connect to rstudio server, I even tried it over my mobile connection on my phone to see if it was a pc/institute connection issue but I still get the same result

We've just carried out maintenance, maybe which may have caused this second break...

I believe that was the problem now, it seems to be back to working again, thank you!