Dynverse package and singularity

Bonjour,
Le package Dynverse (https://dynverse.org/) sur Rstudio requiert l'installation de Singularity (User Guide — Singularity container 3.0 documentation) (version ≥ 3.0).
Serait-il possible de l'installer, svp? (Je n'ai pas été en mesure de la faire moi même).

Cordialement.

Pierre

Bonjour @pcattenoz,

Singularity est déjà disponible sur le cluster :

$ module load singularity
$ singularity --version
singularity version 3.5.3

Par contre, je ne vois pas comment vous pensez l'articuler avec RStudio ?

Je ne vois pas non plus comment l'articuler avec Rstudio.
J'espérais naïvement que le package dynverse puisse y accéder sans mon intervention.

Merci pour votre réponse, je vais essayer de faire tourner le package localement.

Si ça n'est pas le cas, nous pourrions mettre Singularity explicitement dans le $PATH.

Voici la réponse que j'obtiens lorsque je test dynverse avec la commande suivante:
#################

dynwrap::test_singularity_installation(detailed = TRUE)
Error in dynwrap::test_singularity_installation(detailed = TRUE) :
:x: Singularity (>= 3.0) could not be found. Install the latest stable release from: https://github.com/sylabs/singularity/releases.
###################
Je veux bien tester avec Singularity dans le $PATH.

Merci beaucoup.

Hum ... singularity n'est en effet pas installé sur le serveur RStudio.
Nous vous tenons au courant

Désolé, je n'ai pas eu le temps de m'y remettre

De mon coté, je n'ai pas réussi à faire fonctionner le package localement (en utilisant docker à la place de singularity).

Singularity est maintenant disponible sur Rstudio.

Merci beaucoup!