Error with srun

Good morning,

when I run a script with srun (for example srun ./ in login2 I obtain following error.
srun: error: io_init_msg_unpack: unpack error
srun: error: io_init_msg_read_from_fd: io_init_msg_unpack failed: rc=-1
srun: error: failed reading io init message

I have tried in login1 and I have another error:
slurmstepd: error: Detected 1 oom-kill event(s) in StepId=37634868.0. Some of your processes may have been killed by the cgroup out-of-memory handler.
srun: error: cpu-node-33: task 0: Out Of Memory

How can I solve it svp?

Hello Arianna,

Concerning the srun error from login2, it is due to some outdated computing nodes. We have disabled these nodes for now. They should be back soon.

Concerning the error from login1, it is a more simple "out of memory" error. This means that the process you launched has been using more memory than what you have reserved. I would suggest to simply increase the memory reserved.

Best regards,


Hello Julien,

ok thank you so much.