Install Python kernel in Jupyter notebook

Hi all,
I am using jupyter notebook on the cluster and I need to use Python 3.7. However, in jupyter notebook there is only kernel Python 3.9 available. I tried to install a new kernel following instructions (

!module load usc python/
!python -m ipykernel install --user --name py376 --display-name “Python 3.7.6”

However, I cannot use module load command in a notebook and so it creates a new kernel with name Python 3.7.6 but it is still python 3.9

Hi @Arianna_Tonazzolli ,

We had a small failure on our Python 3.7 kernel following an update done yesterday. The python 3.7 kernel is now operational again and includes a lot of pre-installed libraries (pandas, numpy, scikit, tensorflow, pytorch, etc.).

You can install additional packages if necessary by using the pip command from a code cell:

!pip install <package>

Best regards,


Dear Julien,

thank you so much for quick reply. I woudl like to use Jupyter notebook but I cannot open it.

A red bar with "Spawn failed: Timeout" is shown when I try to launch it on Google Chrome

And this

[I 09:48:29.353 NotebookApp] Serving notebooks from local directory: /shared/ifbstor1/projects/emergen_hera_eqa
[I 09:48:29.353 NotebookApp] Jupyter Notebook 6.4.11 is running at:
[I 09:48:29.353 NotebookApp] http://localhost:8888/?token=d3a22ae9891eeb02e600892e519589db0d195e3e1deb860d
[I 09:48:29.353 NotebookApp] or
[I 09:48:29.353 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[E 09:48:29.354 NotebookApp] Failed to write server-info to /shared/ifbstor1/home/atonazzolli/.local/share/jupyter/runtime/nbserver-10186.json: [Errno 122] Disk quota exceeded: '/shared/ifbstor1/home/atonazzolli/.local/share/jupyter/runtime/nbserver-10186.json'
Traceback (most recent call last):
File "/shared/ifbstor1/software/miniconda/envs/python-pytorch-tensorflow-3.9-1.11.0-2.6.2/bin/jupyter-notebook", line 10, in <module>
File "/shared/home/atonazzolli/.local/lib/python3.9/site-packages/jupyter_core/[](", line 269, in launch_instance
return super().launch_instance(argv=argv, **kwargs)
File "/shared/home/atonazzolli/.local/lib/python3.9/site-packages/traitlets/config/[](", line 965, in launch_instance
File "/shared/ifbstor1/software/miniconda/envs/python-pytorch-tensorflow-3.9-1.11.0-2.6.2/lib/python3.9/site-packages/notebook/[](", line 2336, in start
File "/shared/ifbstor1/software/miniconda/envs/python-pytorch-tensorflow-3.9-1.11.0-2.6.2/lib/python3.9/site-packages/notebook/[](", line 2239, in write_browser_open_file
with open(self.browser_open_file, 'w', encoding='utf-8') as f:
OSError: [Errno 122] Disk quota exceeded: '/shared/ifbstor1/home/atonazzolli/.local/share/jupyter/runtime/nbserver-10186-open.html'

when I try to launch it in CLI

Is there an issue on the cluster today or did I made something wrong?

Hello Arianna,

It appears that you have reach your inodes quota on your home directory. This means that you have created more than the 100000 files allowed.
You will have to delete files or move data to your project folders in order to leave more space on your homedir.

Best regards,


Hi Julien,

Thanks, I am in Jupyter notebook now but when I try to change kernel, I cannot find Python 3.7. Kernel Python 3.7.6 is the one that I have created as I said before but it is python 3.9

How can I have a kernel of Python 3.7?

Your kernel python3 is overwriting the default Python 3.7 kernel provided by IFB.
Could you please rename your python3 kernel (located in ~/.local/share/jupyter/kernels/ in your homedir)/



Now it works. Merci beaucoup pour ton aide.