Install rMATS_turbo_4.1 & dependecies

Dear IFB-team,
I d like your help with a tool I am trying to install locally.
https://rMATS-turbo . It's for alternative Splicing detection.
I ran it by loading python/2.7, (only other option is 3.6).
I also installed in /home/mk/Tools_Packages/gsl-2.6/ the GSL package and configured it because I didn't find any as a module.
If there is a way to call it from existing bin/ in cluster, let me know.

Other dependecies to verify if we have (please let me know how I could see myself in the future) :

  • Cython (0.29.14)
  • numpy (1.16.5)
  • BLAS, LAPACK
  • GCC (5.4.0)
  • gfortran (Fortran 77)
  • CMake (3.15.4)

I get the following error during the ./build_rmats :

rm: cannot remove ‘*.dylib’: No such file or directory make: [build] Error 1 (ignored) cd rMATS_C; make; make[1]: Entering directory "/shared/ifbstor1/home/mkondili/Tools_Packages/rMATS_turbo_4.1.0/rMATS_C" .
some other src/ scripts are runnning , and then .. :
/usr/bin/ld: cannot find -lblas
/usr/bin/ld: cannot find -llapack
collect2: error: ld returned 1 exit status
make[1]: *** [rMATSexe] Error 1

Do you have an idea if these errors are due to dependencies or something else wrong during installation ?

Is it possible to install it globally as module if all deps are existing
(at least for some time until I run it) ?

Unfortunately, only rmats is available as a Conda package: https://anaconda.org/bioconda/rmats

We would build a Conda package in Bioconda but it's take time and human. Can you advice Conda/Bioconda to the rmats-turbo developers?

And before investing time, do you have good feedback on this tool or is it for testing purpose?

In the meantime, did you try with the option ./build_rmats --conda.

Hello Gildas, I installed the conda package 4.1.0, like this:

module load conda
conda activate conda_env #  /shared/home/mkondili/.conda/envs/conda_env
conda install  -c bioconda rmats

Thanks for the recommendation. This would be fine too.
But how can I run it now ?
I cannot import it as a python package inside python env. (no module named ..!),
and don't know where is the main script saved.
Their tutorial suggests to call it via command-line as :
python rmats.py

I need it initially for testing, I found it from a study published, but if it works I could use it on my analysis recurrently.

Maybe you will be able to find it with a command like this one :

find ~/.conda -name rmats.py

If you were interesting in rmats, we can easily install it as a module. Don't bother you to install it on your own.

Just request it. But I though that you were focus on rmats-turbo that "should be" quicker.

Well, for the moment I couldn't be very demanding,because I need to run it as soon as possible.
So, if you can install it as a module that would be great.
It was a good practise for me to learn how to install it locally anyway, no problem.

I don't know how "slow" can this one be,compared to turbo, in practice(they say 100x for turbo!). I only have 9 samples to run. I ll use the max of threads possible though.

Oki, it should be installed within this afternoon

Hop

module load rmats/4.1.0

Would it be too much to ask to update the version of this, because new one is published : 4.1.1 in https://anaconda.org/bioconda/rmats
It gives more verbose msg in errors so it is more useful. You can delete the 4.1.0.

Really too much :stuck_out_tongue:

I will do that!

WIP: