Loading slurm-drmaa while using a conda environment

I need to use a software that I installed into a conda environment that uses snakemake version 5.32.2. I can run my snakefile without problems but when I include --drmaa it says it can't find the drmaa module, even after doing:

module load slurm-drmaa

While trying to install the module myself I must have done something silly because now echo $DRMAA_LIBRARY_PATH gives me an empty path. Could you help me fix this, even for using drmaa without the conda environment, since now I can't use --drmaa with other snakefiles?


Hi asilva,

I had the same problem ( but with snakemake/5.19.2), I solved it by using

module load slurm-drmaa/1.0.8

I hope it works for you too.

have a nice day,


1 « J'aime »

Hi Lucie,
Thanks for your input, I tried with snakemake/5.19.2 with drmaa but then realize it was my script that couldn't work with the 5.19.12 version (not sure what changed between versions), and when I tried to fix drmaa to work for my conda environment 5.3 version I must have done something weird to the drmaa path that now I can't use it at all, so this is another thing that needs be fixed and I am not sure how.


Hello Ana,

To reset your environment or paths, simply log out and log back in.
Did you just try module show slurm-drmaa / 1.0.8 and use your conda environment?

We can try installing the [phyluce] software (https://anaconda.org/bioconda/phyluce) if you wish.

Apologies for not replying earlier. To log out and then back in seemed to have been enough for slurm-drmaa to work fine, however, I still had some incompatibility issue between using snakemake version on phyluce environment and slurm-drmaa/1.0.8 so I just end up running without using drmaa, it was slower but did the job.