Metagenomics Mothur

I have tried to align sequnces to Silva several times and now with GreenGens,on Meatagenomics/ mothur pipeline, but it still don't working,

can you tell me please what have I to do? I used primers for the V3/V4 region of the rRNA 16S.
Here's the error message "This job was terminated because it used more memory than it was allocated." and it was impossible to report the error, i've got this message "An error occurred sending the report by email: Mail is not configured for this Galaxy instance"
Any help would be greatly appreciated!

Hello Emma,

It seems that you are working on a Galaxy server.
I didn't know that the Galaxy server of the IFB was in production.

Obviously it's a ressources problem, that you can't modify as a user.
Normally on galaxy when you have a "red dataset", you can click on the bug symbol to directlty contact the support team of the Galaxy, who will have access to your history and so check if there is an other problem with your data.
Did you test this solution ?

I know that you tested also FROGS on the Galaxy server of Toulouse ( Does my previous email help you?

Have a nice day


Hello Maria,
the Galaxy server of the IFB was in production, but once I clicked on the bug symbol to contact the support team, this message "An error occurred sending the report by email: Mail is not configured for this Galaxy instance" appears.

I have to thank for your help in your previous email. I tried FROGS and it works well :slight_smile: , but I'm trying to work on mothur too, that's why I find this issue on alignment with bank datasets.
In my work, I have a part where I have to use two tools at least to make clusters on my data
Have a nice day too

We can consider that is in prodution :slight_smile:
It's just we didn't communicate on that so far.

So, can you give me the exact name of the tool you are using ? I will increase the memory available.

Oups, we have to fix that. Thanks for the report.

I'm using Mothur

There are a lot of tools in the Mothur section. I think that @gildaslecorguille need the exact tool name that returned you the memory error.


I would better recommand you to use QIIME (which is also available in Galaxy), if your sequences come from Illumina technology.

:tada: :clap:

Sorry for being unclear, I was talking about the "Align.seqs" tool, my inputs is the fasta file from "Unique.seq" and for the reference, I tried Silva and then GreenGens.
thanks for your recommandation, indeed my sequences come from Illumina Miseq

So far, we give 2GB with a resubmit at 3GB for this tool.

Should we increase to 4GB -> 6GB or higher?


I do not have a big experience of mothur analysis, but when we compared FROGS to mothur we launch a full workflow with mem=15G and h_vmem=18G.

This give you an idea but I could not say if the align.seq was the most consuming step, and it depdends also of the number of sequences.

I have about 171 000 sequences, i don't know if it can help

We had at most 850 000 sequences as input of align.seq.

@gildaslecorguille you could try with 4 to 6 G and Emma will soon tell us if it works.

Hi here,
Now, Mothur Align.seqs can use a maximum of 6GB of memory.