Need for metaMS version 2.1.1. for the new W4M platform

Dear support team,

I have a published workflow that is cited in an ongoing article (in-revision). I am trying to migrated it to the new platform in order to avoid its disappearing after 31/12/2020.

However, the problem is that the mentioned workflow is based on metaMS version 2.1.1., that is apparently not accessible in the new W4M instance.

Is there any possibility to resolve this problem? Since my results in the paper are based on the processing done using this workflow.

Thank you in advance.

Hikmat

Hello Hikmat,

I have just installed the version yguitton/metams_runGC/3.0.0+metaMS1.22.0-galaxy0
Can you check that it's the matching version?

Hello Gildas,

For workflow construction, now it seems OK.
However, I tried to run my dataset using it, and I got the following error:

An error occurred while running the tool toolshed.g2.bx.psu.edu/repos/yguitton/metams_rungc/metams_runGC/2.1.1 .

Hi Hikmat,
The error message you wrote is not complete enough for us to be able to determine what the problem is.
Since it is about data that is meant to be shared anyway, would you mind making your history accessible via link and share the link here, for us to have access to the complete error message?
If not possible, you can find more information about your error by checking the stdout and stderr section in the information view of your concerned job. Can you copy and paste the corresponding content here please?

Hello Mélanie,

Please find the access path to the history on the link below:

https://workflow4metabolomics.usegalaxy.fr/u/hikmatghosson/h/online-hs-spme-gc-ms-based-untargeted-volatile-metabolomics-for-studying-emerging-complex-biopesticides-a-proof-of-concept---w4m-data

Ok, I will check that!

Thank you !

Hi @hikmatghosson,

Sorry for the delay.
It's should be ok now.

Dear Gildas,

I tried to test the workflow by processing my data using the same method. Now I've got a new error message:

Loading required package: methods
Loading required package: CAMERA
Loading required package: Biobase
Loading required package: BiocGenerics
Loading required package: parallel

Attaching package: ‘BiocGenerics’

The following objects are masked from ‘package:parallel’:

clusterApply, clusterApplyLB, clusterCall, clusterEvalQ,
clusterExport, clusterMap, parApply, parCapply, parLapply,
parLapplyLB, parRapply, parSapply, parSapplyLB

The following objects are masked from ‘package:stats’:

IQR, mad, sd, var, xtabs

The following objects are masked from ‘package:base’:

anyDuplicated, append, as.data.frame, basename, cbind, colMeans,
colnames, colSums, dirname, do.call, duplicated, eval, evalq,
Filter, Find, get, grep, grepl, intersect, is.unsorted, lapply,
lengths, Map, mapply, match, mget, order, paste, pmax, pmax.int,
pmin, pmin.int, Position, rank, rbind, Reduce, rowMeans, rownames,
rowSums, sapply, setdiff, sort, table, tapply, union, unique,
unsplit, which, which.max, which.min

Welcome to Bioconductor

Vignettes contain introductory material; view with
'browseVignettes()'. To cite Bioconductor, see
'citation("Biobase")', and for packages 'citation("pkgname")'.

Loading required package: xcms
Loading required package: mzR
Loading required package: Rcpp
Error: package or namespace load failed for ‘mzR’ in dyn.load(file, DLLpath = DLLpath, ...):
unable to load shared object '/shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/mulled-v1-0ae988a4d0b8164ca82b07484a596bc492f704ad86ba31c19cdaca893b7f2f88/lib/R/library/mzR/libs/mzR.so':
libnetcdf.so.11: cannot open shared object file: No such file or directory
Error: package ‘mzR’ could not be loaded
Execution halted

A classic :stuck_out_tongue:

@hikmatghosson NEXT TRY :rocket:

For records
$ /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/bin/python /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/bin/conda create --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --name mulled-v1-0ae988a4d0b8164ca82b07484a596bc492f704ad86ba31c19cdaca893b7f2f88 bioconductor-metams=1.14.0 r-batch=1.1_4
$ . /shared/galaxy/mutable-data/dependencies/_conda/bin/activate mulled-v1-0ae988a4d0b8164ca82b07484a596bc492f704ad86ba31c19cdaca893b7f2f88
$ conda install --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --channel https://repo.anaconda.com/pkgs/free libnetcdf=4.3.3.1
$ conda install --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --channel https://repo.anaconda.com/pkgs/free bioconductor-mzr=2.6.3=r3.4.1_1
$ conda list

# packages in environment at /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/mulled-v1-0ae988a4d0b8164ca82b07484a596bc492f704ad86ba31c19cdaca893b7f2f88:
#
# Name                    Version                   Build  Channel
_libgcc_mutex             0.1                 conda_forge    conda-forge
_openmp_mutex             4.5                       0_gnu    conda-forge
_r-mutex                  1.0.1               anacondar_1    conda-forge
bioconductor-biobase      2.40.0           r341h470a237_0    bioconda
bioconductor-biocgenerics 0.26.0                   r341_0    bioconda
bioconductor-biocparallel 1.14.2           r341h26a2512_0    bioconda
bioconductor-camera       1.34.0           r341ha44fe06_2    bioconda
bioconductor-graph        1.58.2           r341h470a237_0    bioconda
bioconductor-massspecwavelet 1.46.0           r341h470a237_0    bioconda
bioconductor-metams       1.14.0                 r3.4.1_0    bioconda
bioconductor-multtest     2.36.0           r341h470a237_0    bioconda
bioconductor-mzr          2.6.3                  r3.4.1_1    bioconda
bioconductor-protgenerics 1.12.0                   r341_0    bioconda
bioconductor-rbgl         1.56.0           r341hfc679d8_0    bioconda
bioconductor-s4vectors    0.18.3           r341h470a237_0    bioconda
bioconductor-xcms         1.50.1                 r3.4.1_0    bioconda
[...]
hdf5                      1.8.15.1                      3    https://repo.anaconda.com/pkgs/free
[...]
libnetcdf                 4.3.3.1                       3    https://repo.anaconda.com/pkgs/free
[...]
ncurses                   5.9                          10    conda-forge
[...]
python                    3.6.5                         1    conda-forge
[...]
r-base                    3.4.1                         4    conda-forge
[...]
r-batch                   1.1_4                    r341_1    conda-forge
[...]

Now the error mentioned previously has returned :sweat_smile: :hammer:

An error occurred while running the tool toolshed.g2.bx.psu.edu/repos/yguitton/metams_rungc/metams_runGC/2.1.1 .

Not exactly. The current error is due to huge memory usage.

This job was terminated because it used more memory than it was allocated.

@gildaslecorguille may be able to adjust for that, but there could be some delay since it is currently summer break period.

Thank you in advance for your patience.

I would like to thank you anyway.

I'm sorry but I'm currently on holidays :beach_umbrella:. I will be back from the 24th of August.

Maybe someone else from the @team.w4m can help here?

1 J'aime

I have the same problem for the CAMERA.annotate which I need in the version "Galaxy Version 2.2.4"

would it be possible to also restore this version of the tool?

Can you share an history with me?

Installation in progress :+1:

Hop
CAMERA.annotate 2.2.4 is now available in https://workflow4metabolomics.usegalaxy.fr