NMR_read of Jeol data


In the past I've made some attempts with Bruker NMR data preprocessing, alignment, bucketing and normalization via the W4M platform. Now, for the first time, I obtained data from a Jeol instrument and I'm trying to read them on the W4M platform as well. I've seen that "Bruker NMR raw files" are mentioned here, but I hoped I could also manage to use the platform with my Jeol data. However, when I try to read the data, I get a notification that there are no valid FIDs.

What did I do so far? I took the .jdf files from the Jeol instrument and opened them in MestreNova, there I saved them as .jcamp and these spectra I was able to open in TopSpin. I performed phase correction and baseline correction and calibration manually, placed my files with different exp. no. in a single folder, zipped the folder and uploaded it. However, I saw that my files only contain an acqu, acqus file and a pdata folder. There is no fid file... In TopSpin, I tried to save my data in another form, namely "1r/1j as fid". I added the then obtained fid to my original file, where the acqu and acqus already were and tried to read the data again, but it also didn't work.
My question is: is there a way to work with Jeol data, or has this not been done yet and/or is it impossible?
Hopefully there is a way to process my data with W4M!
Thanks in advance for your reply.

Kind regards,

Ping @team.w4m

Dear Emmy,

Only Bruker files are currently supported in W4M. But, you can run the different steps you listed in your message (open in MestreNova, save as .jcamp, open in TopSpin. Perform phase correction, baseline correction and calibration, place files with different exp. no. in a single folder, zip the folder and upload it). You can then perform Alignment, Fixed siez bucketing ad normalisation from downloaded zip in W4M. I looked at the readnmr script : acqus file and 1r and procs in the pdata/1 folder are needed
If you wand you can share your history with me (marie.tremblay-franco@inrae.fr)
If you need help, please feel free!


Dear Marie,

Thank you for your reply. I do have the acqus file and the 1r and procs files in the pdata/1 folder, so that should be OK. Do I understand well that I skip the NMR_read step on W4M then? Because if I try to perform alignment as first step after uploading my zip file with the spectral data, I get an error message saying:
" Loading required package: MassSpecWavelet
Loading required package: waveslim

waveslim: Wavelet Method for 1/2/3D Signals (version =

Error in setwd(SampleDir) : cannot change working directory
Calls: nmr.alignment -> NmrRead -> setwd
Execution halted"

So it seems that the NmrRead perhaps can not be skipped?

Last week I shared my history with you and normally you should have access to it. If you have time, could you please have a look?
Thank you!

Kind regards,