Pangolin module raises dependency missing error

When trying to load pangolin environments using module load pangolin/XXX the following error is raised:

Error: Missing dependency `pysam`.
Please update your pangolin environment.

This happens for all available versions:


Loading the pysam/0.16.0 or the python/3.9 modules doesn't solve the problem.

Would force reinstalling the conda environments for pangolin maybe fix the issue ? Pangolin was working fine up until last tuesday (18/04/2022 is the last time it worked for me).

I tried installing it in a user-specific conda env but I am running into a lot of packages conflicts issues (I only tried to do that for pangolin 4.2 and 4.1.1 however)


Hello Arthur,

I can't reproduce this issue.
Could you simply retry (after disconect/reconnect your session) or give me the command lines to reproduce this error ?

Indeed it seems it is specific to my session, it looks like pangolin is already installed without activating any conda env or loading a pangolin module, and it is missing its dependencies. It was located in my ~/.local/bin folder. I removed it but it looks like it still remains: when loading pangolin/4.2 the pangolin version is still 3.1.17 (the version of my "local" pangolin) and the dependency error remains.

Reloading my session didn't solve the issue. I'll continue investigating, thanks David

I found the issue, in ~/.local/lib/python3.8/site-packages there was an old install of pangolin that overrode what was being loaded using the module command. It's my bad, it's probably been a while it has been here, although it didn't cause any problem before last week.

Great. Thank you for the feedback.