Problème de chargement de fichier

Bonjour,
je rencontre un problème très particulier depuis hier : je n'arrive pas à uploader mes fichiers de Data Matrix sur W4M, alors que les autres fichiers (sample metadata, variable metadata) se chargent normalement. Il s'agit pourtant tous de .tsv, que j'ai déjà chargés sans problème par le passé.

Message :
tool error

Une erreur est survenue avec ce jeu de données:

[Errno 2] No such file or directory: SafeStringWrapper(str:__lt__class sq__NoneType__sq____gt,__lt__class sq__NotImplementedType__sq____gt,__lt__class sq__bool__sq____gt,__lt__class sq__bytearray__sq____gt,_lt__class sq__ellipsis__sq

D'avance merci pour votre aide.
Thibaud

Bonjour,
Je rencontre le même problème.
Le simple fait de télécharger la dataMatrix et de tenter de l'uploader à nouveau dans W4M ne fonctionne pas et génère le même message d'erreur.
Merci d'avance pour votre aide.

Damien

Bonjour,
Je n'ai pas réussi à reproduire le problème, de mon côté les fichiers de type dataMatrix se chargent normalement.
Pourriez-vous partager un exemple de fichier qui pose problème ?
Par avance merci,
Mélanie

Bonjour,
Voici 2 exemples récents et un plus ancien (qui marchait, mais qui ne fonctionne plus aujourd'hui).
https://filesender.renater.fr/?s=download&token=f1f53d37-e894-4a1c-9469-e81257314fa4
Damien

Il semblerait que le soucis vienne d'un format sniffé. En effet, si on spécifie à l'import que les fichiers sont des "tabular", alors pas de soucis, les fichiers s'importent bien. Par contre si on laisse le sniffer à l’œuvre pour déterminer le datatype, alors il y a erreur et pas d'import.

@team.galaxy Y a-t-il eu un changement au niveau du sniffer de datatype ? Je ne m'y connais pas tellement, mais il se pourrait qu'un format plus "haut" dans la liste pose problème pour certains fichiers tabulés type dataMatrix ?

Effectivement, cela semble fonctionner en spécifiant à l'import le type de fichier, merci beaucoup.
Je n'avais jamais eu recourt à ça puisque ça fonctionnait bien jusqu'à il y a quelques jours..

1 « J'aime »

Nous allons regarder ça !

Je confirme également qu'en sélectionnant le type "tabular", mes fichiers peuvent de nouveau être chargés. Merci pour votre aide.

Bonjour @Thibaud

Il y avait un problème de mémoire sur l'upload qui a été corrigé.
Je viens d'essayer sans sélectionner tabular et ça a fonctionné.
Pouvez vous nous confirmez ?

Bonne journée

Bonjour,
Ca fonctionne également de mon côté. Merci beaucoup d'avoir solutionner ce problème.
Bonne fin de journée
Thibaud