Problème unicycler/spades

Bonjour,

je voudrais faire tourner unicycler sur mon jeu de données mais il semble qu'il y ait un problème avec la suite samtools (cf sortie d'erreur suivante). pourriez vous y remédier ?? :slight_smile: Merci beaucoup par avance pour votre retour ! Chloé

 Program         Version   Status     Path
  spades.py       3.14.1    good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /spades.py
  racon           1.4.13    good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /racon
  makeblastdb     2.10.1+   good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /makeblastdb
  tblastn         2.10.1+   good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /tblastn
  bowtie2-build   2.4.2     good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /bowtie2-build
  bowtie2         2.4.2     good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /bowtie2
  **samtools        ?         too old    /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin**
**                                       /samtools**
  java            11.0.1    good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /java
  pilon           1.23      good       /shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin
                                       /pilon
  bcftools                  not used

Error: Unspecified error with Unicycler dependencies

@team.ifbcorecluster il y a en fait une mise à jour de la dépendance samtools imposée pour qu'uncicyler puisse fonctionner. Merci par avance pour votre retour et bonne journée
Chloé

Il y a surtout un problème sur le package samtools livré avec Unicycler

$ module load unicycler/0.4.8
$ samtools --version
samtools: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

Nous allons réinstallé unicyler

Tu peux réessayer ?

merci beaucoup @gildaslecorguille !
la dépendance samtools fonctionne mais la c'est Spades qui crash

== Error == system call for: "['/shared/ifbstor1/software/miniconda/envs/unicycler-0.4.8/bin/spades-hammer', '/shared/projects/mbovis_diversity/Assembly_ONT/1_Unicycler/spades_assembly/read_correction/corrected/configs/config.info']" finished abnormally, OS return value: 255ESC[0m
In case you have troubles running SPAdes, you can write to spades.support@cab.spbu.ruESC[0m
or report an issue on our GitHub repository github.com/ablab/spadesESC[0m
Please provide us with params.txt and spades.log files from the output directory.ESC[0m
SPAdes log can be found here: /shared/projects/mbovis_diversity/Assembly_ONT/1_Unicycler/spades_assembly/read_correction/spades.logESC[0m
Thank you for using SPAdes!ESC[0m
Error: SPAdes crashed! Please view spades.log for more information.
srun: error: cpu-node-17: task 0: Exited with exit code 1

et je ne comprends pas ce qui bloque dans le fichier spades.log ....aaah je suis désolée

Bonjour @Chloe,

Désolé de ne revenir vers vous que maintenant, mais je ne vois pas ce qui peut poser problème.
Avez-vous trouvé une solution ?

Bonjour,

J'ai eu le meme problème avec SPAdes hier.
== Error == system call for: "['/shared/software/miniconda/envs/spades-3.14.1/bin/spades-hammer', '/projet/sbr/sometag/finalresult/deep_MOBY/000_SPAdes/M2_350m/corrected/configs/config.info']" finished abnormally, OS return value: -9

J'ai trouvé ça comme réponse:

"The problem is likely due to your cluster configuration. You may need to talk to your system administrator about this"

Est-ce que vous avez trouvé une solution ?
Merci beaucoup.
Cordialement,
Pavla

Est-ce qu'il ne lui faudrait pas plus de mémoire à SPADES que les 2GB par défaut ?

En regardant un peu autour, j'ai l'impression qu'il demande plus dans les 100GB - 200GB. Peut-être commencé avec 100GB ?

#SBATCH --mem 100GB

Bonjour Palva
Il me semble que dans ton cas l'erreur venait du fait que tu ne spécifiais pas la mémoire a allouer dans ta ligne de commande spades (par default spades utilises 250 Gb ->p. ex. -m 100) et qu'elle n'était pas non plus renseignée dans les paramètres de ton script slurm (p.ex. #$BATCH -mem 100GB)

Amicalement
Erwan

1 J'aime