RSAT Matrix Clustering Error

I have been tryint to use the Matrix Clustering tool of RSAT and I have been encountering the same error over and ovestaysain.

Initially I submitted my own data but as it always failed to complete it, I tried to run the Demo 1 and Demo 2 sets and still received the same error message as shown below.

Server command

$RSAT/perl-scripts/matrix-clustering -v 1 -max_matrices 300 -matrix 'oct4_peak_motifs' $RSAT/public_html/tmp/apache/2023/10/03/matrix-clustering_2023-10-03.111558_mQVU9x/matrix-clustering_query_matrices.transfac transfac -hclust_method average -calc sum -title ''oct4_motifs_found_in_chen_2008_peak_sets'' -metric_build_tree 'Ncor' -lth w 5 -lth cor 0.6 -lth Ncor 0.4 -quick -label_in_tree name -return json,heatmap -o $RSAT/public_html/tmp/apache/2023/10/03/matrix-clustering_2023-10-03.111558_mQVU9x/matrix-clustering 2> $RSAT/public_html/tmp/apache/2023/10/03/matrix-clustering_2023-10-03.111558_mQVU9x/matrix-clustering_err.txt

Error log: $RSAT/public_html/tmp/apache/2023/10/03/matrix-clustering_2023-10-03.111558_mQVU9x/matrix-clustering_err.txt

In essence, it never computes the results. If you click on the result link it stays on computing it for over a week and never finishes.

If this could be fixed I would be tremendously thankful.

I also tried to reach out to the team but I couldnt access the RSAT forum and when I tried emailling the email bounced back. So any help would be very appreciated.