Trying to build new version of Masurca - Cannot find zlib library

Hi,
I am having an issue while running Polca which is within Masurca and this issue seems to have been solved in a more recent version Polca sequence does not match the original · Issue #191 · alekseyzimin/masurca · GitHub. However, I am not being able to overcome a compiling issue related with the zlib library. In their website they don't advise to install Masurca using conda but by compilling it myself I run into:

configure: error: in `/shared/home/asilva/MaSuRCA-4.0.3/global-1':
configure: error: Cannot find zlib library. Install zlib libray

I think likely this zlib is somewhere so I could set that path but I am not sure how to find it. Anyway you could help me? I think I have had this issue before of not finding some libraries, even after doing module load htslib.

Thanks for any help you can provide
Cheers,
Ana

Hello,

I think zlib and some of other usefull lib for compilation are availlable in gcc env:

module load gcc/7.5.5

or

module load gcc/8.4.0

or

module load gcc/9.3.0

we may also install the last version of masurca, as it is availlable in conda.

Thanks for your reply,
I had tried to compile with all three available gcc modules, I think it's more a matter of finding the right path.

They have a warning about bioconda installation: 'WARNING: installing MaSuRCA via Bioconda is not supported'. I don't know if the most recent version is there or not but I guess is worth trying to see if it works to fix the problem.

Thanks
Ana

MaSuRCA 3.4.2 is now installed, please could you try it and inform us if it solve your issue or not.

1 J'aime