XCMS-trouble with xcmsfindchrompeakMerger


J’ai lancé 4 XCMS sur la nouvelle instance Galaxy

2 XCMS contenant moins de 100 echantillons sont passés super vite et sans souci

Depuis vendredi, j’ai lancé 2 autres XCMS d’une cohorte de 383 echantillons et ca ne passe pas !

Ca bloque sur la brique xcmsfindChromPeak Merger

J’ai le message “his job was terminated because it used more memory than it was allocated.”

Dataset Error

An error occurred while running the tool toolshed.g2.bx.psu.edu/repos/lecorguille/xcms_merge/xcms_merge/3.6.1+galaxy0 .

Est-ce que vous pourriez regarder quel pourrait être le problème svp ?

Merci d’avance pour votre aide

Bonne journée


Hi, my XCMS workflow applicated to a list with 383 items doesn't work and became red at the step xset.merged.RData.
The message is " Job was terminated because it used more memory than it was allocated"
I am stopped their just before the Group and I can't go ahead anymore ...

The same worklow with a list of 92 items worked without any trouble to the end of the process.

Could you help me please ?
I have to process this study and the next bigger one wich will contain arount 900 items.


Hi Florence,

It seems your problem is linked to the fact that some XCMS steps may require substancial memory while dealing with huge datasets. We also faced this problem in "old" instance and had to configure the galaxy instance to allow job re-submission with more allocated memory for XCMS modules. I guess we need to do the same with the new instance.

I am not qualified to do this kind of modifications. @gildaslecorguille is this something you can handle? Based on last year frequent occurence of this issue during summer, I expect this to happen often very soon.


We also have the same mecanism of resubmition.
But merge wasn't setted properly.

It's in progress and should be oki within the morning :slight_smile:

It should be ok now.
@fcastelli can you relaunch your job?

xcms_merge will now be able to use 8, or 16 and finally 32GB is needed

I relaunched this afternoon and XCMS-merge is green !!!
the rest of my XCMS workflow is running but it should be ok :slight_smile:
thanks !

Unfortunaltly, the XCMS workflow stopped rapidely at the next step "GROUP" with the same error : "This job was terminated because it used more memory than it was allocated."
HELP !!!

I will also increase the memory available for group.

Should be ok now
xcms group can now use from 8GB to 16GB.

Thanks Gildas
I can not relaunch the job because impossible to connect to "https://workflow4metabolomics.usegalaxy.fr/"
I will try later in the morning.

I hope t will be ok and my process will success untill the end of the workflow (after retcor, fillpeak and camera)

to be continued ...

Hi Gildas
I tried and a new error message appeared : "Encountered an unhandled exception while caching job destination dynamic rule."
could you help me ?

Sorry, it's fix now!