CAMERA: Conda dependency seemingly installed but failed to build job environment


While re-runing workflows from the old W4M instance in the new one, I encountered the "Conda dependency" problem when running CAMERA on an old version:

This was originally with CAMERA 2.2.0. I also tried with 2.2.1 version and ended up with the same error message.

For the records, 2.2.4 and later seem to work properly (at least it has been launched and is still running for now), but since they do not provide the same outputs, 2.2.0 version is prefered for the project I am re-running.

Thank you in advance.

I'm on it ... soon!

Fix :v:

For records
$ /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/bin/conda create --quiet --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --name mulled-v1-bc992e514690c52fa4dc473ae4933b4a990f1f279f269d1f17fa2031c5225d95 r-snow bioconductor-camera=1.26.0 bioconductor-multtest r-batch graphicsmagick bioconductor-biobase==2.34.0
$ source /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/bin/activate /shared/mfs/data/galaxy/mutable-data/dependencies/_conda/envs/mulled-v1-bc992e514690c52fa4dc473ae4933b4a990f1f279f269d1f17fa2031c5225d95
$ conda install --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --channel libnetcdf=
$ conda install -y --override-channels --channel iuc --channel conda-forge --channel bioconda --channel defaults --channel bioconductor-mzr=2.6.3=r3.4.1_1
$ conda list
# Name                    Version                   Build  Channel
_libgcc_mutex             0.1                 conda_forge    conda-forge
_openmp_mutex             4.5                       1_gnu    conda-forge
_r-mutex                  1.0.1               anacondar_1    conda-forge
bioconductor-biobase      2.34.0                 r3.4.1_0    bioconda
bioconductor-biocgenerics 0.26.0                   r341_0    bioconda
bioconductor-biocparallel 1.14.2           r341h26a2512_0    bioconda
bioconductor-camera       1.26.0                        0    bioconda
bioconductor-graph        1.58.2           r341h470a237_0    bioconda
bioconductor-massspecwavelet 1.46.0           r341h470a237_0    bioconda
bioconductor-multtest     2.34.0                 r3.4.1_0    bioconda
bioconductor-mzr          2.6.3                  r3.4.1_1    bioconda
bioconductor-protgenerics 1.12.0                   r341_0    bioconda
bioconductor-rbgl         1.56.0           r341hfc679d8_0    bioconda
bioconductor-s4vectors    0.18.3           r341h470a237_0    bioconda
bioconductor-xcms         1.50.1                 r3.4.1_0    bioconda
bioconductor-zlibbioc     1.26.0           r341h470a237_0    bioconda
libnetcdf                              3
python                    3.6.5                         1    conda-forge
r                         3.4.1                  r3.4.1_0    conda-forge
r-base                    3.4.1                         4    conda-forge

Works just fine!
Thanks :nerd_face: